v1.7 Released!

Historical data from Global Markets (such as FX) and those of global interest (such as Indicies, Commodities, etc)

Re: v1.7 Released!

Postby tickstory » Sun Dec 13, 2015 9:49 pm

Hi all,

Due to the substantial number of bug reports and queries arising from the latest MT4 Builds (i.e. 920 and above), we have decided to not update the launcher until we can confirm the platform is stable for back-testing. This includes support for the latest MT4 Build 940 which requires an update to the Tickstory launcher. It appears that MT4 is in the middle of some significant changes, however many of these do not improve or change the back-testing behaviour. As such, the recommendation at this point is to stick to a working Build such as 910. You can find instructions on how to do this here: viewtopic.php?f=2&t=876&p=4062.

We will update this thread when we have further information.

Thanks.
tickstory
 
Posts: 3679
Joined: Sun Jan 06, 2013 12:27 am

Re: v1.7 Released!

Postby Karish » Mon Dec 21, 2015 6:19 pm

tickstory wrote:Hi all,

Due to the substantial number of bug reports and queries arising from the latest MT4 Builds (i.e. 920 and above), we have decided to not update the launcher until we can confirm the platform is stable for back-testing. This includes support for the latest MT4 Build 940 which requires an update to the Tickstory launcher. It appears that MT4 is in the middle of some significant changes, however many of these do not improve or change the back-testing behaviour. As such, the recommendation at this point is to stick to a working Build such as 910. You can find instructions on how to do this here: viewtopic.php?f=2&t=876&p=4062.

We will update this thread when we have further information.

Thanks.


Thanks, Here is my problem.. i suppose that everyone here got the same problem,
Please could somebody post a link to the 1.7.2 please?,
i want to revert back to the 1.7.2 version, the latest 1.7.3 ruined everything... :cry:
BTW, already reverted back to build 910 but something is still wrong... thats why im asking for the 1.7.2 version....

waiting...... thanks for the help..

Image
Karish
 
Posts: 4
Joined: Mon Dec 21, 2015 5:55 pm

Re: v1.7 Released!

Postby tickstory » Mon Dec 21, 2015 9:46 pm

Hi Karish,

Your screenshot shows you are on Build 940, not 910 - this is why the launcher is giving you an error. To prevent MT4 from automatically updating to 940, you will need to roll-back again and then use the /skipupdate configuration parameter (details are provided here: viewtopic.php?f=2&t=876&#p4062. As noted in the mentioned thread, Tickstory has provided no additional functionality between v1.7.2 and v1.7.3 except for support for Build 920. This means that if you are using Build 910, v1.7.3 will work just the same as v1.7.2.

Hope this helps.
tickstory
 
Posts: 3679
Joined: Sun Jan 06, 2013 12:27 am

Re: v1.7 Released!

Postby tickstory » Mon Dec 21, 2015 10:57 pm

Hi all,

For those who are not aware, Build 940 still has a back-testing bug where spread is always zero. This means that even if we decide to provide launcher support Build 940, you will still not able to back-test with this version using fixed spread. The only option available if you want to use Build 940 is to export real-spread and use Birt's TDS (http://tickstory.com/product/birts-tick-data-suite/).

Unfortunately there is lots of noise at the moment that is directly caused by the latest MT4 updates (i.e. Builds 920+). These issues are not Tickstory bugs and are unfortunately beyond our control to fix. By holding back on launcher support for Build 940, we are working in the best interest of our users to ensure you can continue back-testing accurately. If you value moving forward with your back-testing, our advice remains the same - revert to Build 910 until further notice (see here for how to do this: viewtopic.php?f=2&t=876). If you wish to (for some reason) update to the MT4 latest versions, we will not be able to assist you if you are having difficulties. We suggest you report your issues to Metaquotes so they can address them for their next update: http://forum.mql4.com/70645.

Thanks.
tickstory
 
Posts: 3679
Joined: Sun Jan 06, 2013 12:27 am

Re: v1.7 Released!

Postby adaptivefx » Sun Dec 27, 2015 6:56 pm

Hi there,

MT4 is now on build 950, at least with the brokers I am using. I think the zero spread issue has been fixed. Any plans to support build 950?

Thanks,

Mike
adaptivefx
 
Posts: 4
Joined: Sun Dec 27, 2015 6:54 pm

Re: v1.7 Released!

Postby tickstory » Sun Dec 27, 2015 11:21 pm

Hi Mike,

There is some changed behaviour in the latest versions. We are looking into providing support but unfortunately can't give an ETA. There are two options at the moment and that is to either work with Build 910 and the Tickstory launcher or, if you absolutely need to work with the latest version, use Birt's TDS.

We'll obviously update this thread when we have more news.

Thanks.
tickstory
 
Posts: 3679
Joined: Sun Jan 06, 2013 12:27 am

Re: v1.7 Released!

Postby RayShen » Tue Dec 29, 2015 3:08 am

Do you release for build 950?
RayShen
 
Posts: 9
Joined: Thu Oct 01, 2015 3:39 pm

Re: v1.7 Released!

Postby tickstory » Tue Dec 29, 2015 8:05 am

Please read the post above for your answer, RayChen.
Thanks.
tickstory
 
Posts: 3679
Joined: Sun Jan 06, 2013 12:27 am

Re: v1.7 Released!

Postby hans » Tue Dec 29, 2015 10:53 am

Hello,

I have done my own testing and I can see that there is still a problem with spread in Build 950. If your FXT files are read only then the spread from the Strategy Tester box does not work. Birt's TDS tries to work around this problem in v1.4.4 but MODE_SPREAD is still not set correctly. This means that some EAs will still have problems with incorrect back-tests. I already let know Birt about this.

Cheers,

Hans.
hans
 
Posts: 1
Joined: Tue Dec 29, 2015 10:45 am

Re: v1.7 Released!

Postby tickstory » Wed Dec 30, 2015 11:14 pm

Hi Hans,

Thanks for sharing the info. We have confirmed this behaviour as well in Build 950. It appears that the spread "bug" only affects read-only files. We're still assessing the situation and will obviously update this thread when we have any additional workarounds. For the moment, Build 910 is the still recommended way forward.

Regards.
tickstory
 
Posts: 3679
Joined: Sun Jan 06, 2013 12:27 am

PreviousNext

Return to Global

Who is online

Users browsing this forum: No registered users and 52 guests