Dates Missing in back test

General discussion about the Tickstory Lite software package.

Re: Dates Missing in back test

Postby LorraineP » Thu Sep 20, 2018 11:58 pm

tickstory wrote:Hi Lorraine,

Good to hear that the .NET issue is resolved.
Regarding the missing dates, please check this in order:

1) In Tickstory, use the Tools->Show data feature to display the data range you are looking at. Is it there? If yes, it means Tickstory has downloaded the data correctly and everything is ok.
2) In Metatrader, go to the Tools->History Center and ensure the data range exists there. If it does: It's likely your EA that is not trading during the period you mention and you will need to trouble-shoot why (usually this is a parameter causing this). If it doesn't exist, it means something wrong occurred during your export from Tickstory.

Hope this helps.


Hello,
Thanks for the quick reply! So I did step 1, and hit the request button for H4 and H1 (both of which I had checked during download of data). Nothing displays.
See screenshot:
Screen Shot 2018-09-20 at 6.55.48 PM.png
LorraineP
 
Posts: 30
Joined: Tue Aug 21, 2018 7:00 pm

Re: Dates Missing in back test

Postby tickstory » Fri Sep 21, 2018 12:00 am

Hi Lorraine,

We've sent you a private message, could you kindly respond? You can access your inbox/new messages in the top-left menu of this forum.

Thanks.
tickstory
 
Posts: 3450
Joined: Sun Jan 06, 2013 12:27 am

Re: Dates Missing in back test

Postby LorraineP » Fri Sep 21, 2018 11:12 pm

tickstory wrote:Hi Lorraine,

Good to hear that the .NET issue is resolved.
Regarding the missing dates, please check this in order:

1) In Tickstory, use the Tools->Show data feature to display the data range you are looking at. Is it there? If yes, it means Tickstory has downloaded the data correctly and everything is ok.
2) In Metatrader, go to the Tools->History Center and ensure the data range exists there. If it does: It's likely your EA that is not trading during the period you mention and you will need to trouble-shoot why (usually this is a parameter causing this). If it doesn't exist, it means something wrong occurred during your export from Tickstory.

Hope this helps.


Hello,

Thank you for the quick reply. I did step #1 and "No", there is no data there after setting and pushing the "request" button. Nothing appears.
Screen Shot 2018-09-20 at 6.55.48 PM.png
LorraineP
 
Posts: 30
Joined: Tue Aug 21, 2018 7:00 pm

Re: Dates Missing in back test

Postby tickstory » Sat Sep 22, 2018 10:41 pm

Hi Lorraine,

After pressing the 'Request' button, it will take some time to retrieve 2 years of data. Could you instead only display a smaller subset of the data you think is missing such as from Nov 2016 to Dec 2016. Please wait a moment for the information to appear and it should show data for that period. If so, then it means Point #1 is fine.

Thanks.
tickstory
 
Posts: 3450
Joined: Sun Jan 06, 2013 12:27 am

Re: Dates Missing in back test

Postby tickstory » Tue Sep 25, 2018 2:12 am

Hi Lorraine,

As per our discussion offline, please ensure you try download a smaller subset of dates. This will return a result much quicker. After doing this, it appears that all the data is correctly appearing including the dates you mention.
After going through the above-mentioned checks, it also appears that you have correctly exported and the issue seems to be that your EA is not trading during that period for some other reason related to the EA's logic.

Hope this has helped getting you up-and-running!

Regards.
tickstory
 
Posts: 3450
Joined: Sun Jan 06, 2013 12:27 am

Re: Dates Missing in back test

Postby LorraineP » Thu Oct 04, 2018 11:37 am

Hello,
I'm having missing results issues again. This really just stumps me. I've checked and re checked the EA settings. All of the data is there. Why would it only check 10/4/18 when thats not even in the date range I chose?

Screen Shot 2018-10-04 at 6.26.27 AM.png

Screen Shot 2018-10-04 at 6.26.27 AM.png

Screen Shot 2018-10-04 at 6.27.27 AM.png
Attachments
Screen Shot 2018-10-04 at 6.26.44 AM.png
LorraineP
 
Posts: 30
Joined: Tue Aug 21, 2018 7:00 pm

Re: Dates Missing in back test

Postby tickstory » Thu Oct 04, 2018 1:02 pm

Hi Lorraine,

Going from your EA logs, your EA doesn't appear to be entering a new trade since "an open trade has been detected". If this is the case, you'll need to trouble-shoot why the initial trade hasn't been exited yet. Perhaps this is by design?

Hope this helps.
tickstory
 
Posts: 3450
Joined: Sun Jan 06, 2013 12:27 am

Re: Dates Missing in back test

Postby LorraineP » Thu Oct 04, 2018 3:08 pm

No, that didnt help at all. Look at the dates. It only traded on 10/4/18. TODAY.
I have the tester set for 9/22/16 - 10/3/18
LorraineP
 
Posts: 30
Joined: Tue Aug 21, 2018 7:00 pm

Re: Dates Missing in back test

Postby tickstory » Thu Oct 04, 2018 9:33 pm

Hi Lorraine,

Are you referring to the "Time" column in the left-hand side of the "Journal" information you sent a screenshot of? This is a timestamp of when the log activity occurred (i.e. now), not when the trade occurred. I can't see any other reference to Oct 4.

If you want to check the actual date of when a trade is being opened or closed, please use the 'Results' tab. All trade activity should be between the dates you specify.

Thanks.
tickstory
 
Posts: 3450
Joined: Sun Jan 06, 2013 12:27 am

Re: Dates Missing in back test

Postby LorraineP » Fri Oct 05, 2018 12:59 am

Ah Ok, I took the wrong screenshot.

Results page screenshot here. Only took trades on 10/2/2018, even though I have the data for 2 years, and I have the 2 year time frame checked for the strategy tester.

What am I doing wrong here?

Screen Shot 2018-10-04 at 7.58.09 PM.png
LorraineP
 
Posts: 30
Joined: Tue Aug 21, 2018 7:00 pm

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 17 guests

cron