Page 1 of 1

Commison fixing problem(no config file)

PostPosted: Wed Sep 19, 2018 6:04 pm
by SIREN
Dear Tickstory,
I bought your product today,but there is problem I just couldn't solved.I use TICKMILL pro account,it's ECN 2-3pips spread and with around 4.4usd commision per lot.But when I did back test,it use 1.8 pips spread and no commision to run the EA.I searched this forum a lot to get the correct commision,but failed.Please help.Here is the thing related.
I couldn't get the config file in the history folder.(Every step I followed the instruction.)
config file.jpg

I tried to fix the EUR30_0.fxt file...(Because the TICKMILL MT4 only use this file).This is the original parameter:
original.jpg

EUR30_1.fxt is like this below:
EURUSD_01.jpg

I think TICKMILL doesn't use EUR30_1.fxt,every time I changed the EUR30_0,After I launched the MT4 and did back test,the data I put will be wiped out and became the original parameter.
I don't know the coding,I boutht the EA from others,please help to resolve.Thank you!
Best Regards
Terry

Re: Commison fixing problem(no config file)

PostPosted: Wed Sep 19, 2018 11:16 pm
by tickstory
Hi Terry,

Generally speaking, it's always best to keep the same settings that come from your broker. Looks like you are correctly getting the settings from the "Live" account/FXT file. Based on the commission specifications you mention, you could put the following commission settings for your broker:

Comm type: 0 (Money)
Base comm: 4.4
Comm lots: 1 (per lot)

As for the FXT files being overwritten, could you please export again and ensure that the "Make FXT Read-only" check-box is ticked? Just in case, please also confirm this by right-clicking on the *.fxt files in Windows File Explorer and ensuring that the "read only" check-box is checked. This should prevent the FXT files from being overwritten by the back-tester.

Please let us know if there are any issues after this.

Thanks.

Re: Commison fixing problem(no config file)

PostPosted: Thu Sep 20, 2018 10:58 am
by SIREN
Dear,
Today I followed your suggestion,and it worked,though it starts with alert"critical error in EA",after I read some posts,downloaded several months more tick data,and the back-test works greak.It's 99.9.As you can see,it makes some profit.Thank you so much,bro.It gives me confidence about my EA.I like your software and your professional help.
results.jpg

Best Regards
Terry

Re: Commison fixing problem(no config file)

PostPosted: Thu Sep 20, 2018 10:27 pm
by tickstory
That's great to hear, Terry! Thank you for your nice feedback!